If you are using RVM, be sure to specify the patch level for the version of Ruby you want to use, in the .rvmrc file. On some of my apps I had it, and on others I didn’t. When I upgraded RVM to the latest earlier this week, and then CD’d into an app directory, my Mac terminal would close with no visible error message. This was the case for many of my Rails apps, but not all of them. Finally figured out, off a tip from Steve Pothoven (@pothoven), that it was crashing on the apps that didn’t specify the patch level. Once the patch level was specified, all were accessible again.